I want to make everyone aware of a technology decision we’re planning on moving ahead with for Geocortex Essentials 2.0. We’ve decided to increase the minimum .NET Framework for Essentials from 3.0 to 3.5, the latest .NET version. There are a number of compelling reasons for the move, the primary one being our customers' interest and our own interest in leveraging the powerful new features in the latest .NET framework. The Essentials installer will ensure that the necessary prerequisites are installed before installing Essentials 2.0. Also, applications targeted at the 2.0 and 3.0 versions of the .NET framework should remain fully compatible with 3.5.

Please let us know if you have any questions about this.