Geocortex Essentials is ArcGIS Server 10.1 Compliant

Given that a metric by which we get measured is our turnaround time in supporting new Esri product releases, we’re pleased to make the official announcement today that Geocortex Essentials 3.9 (released in May 2012) is ArcGIS Server 10.1 compliant. We’ve been readying Geocortex Essentials for this landmark Esri release over the past several months and have completed final testing to verify compliance. Esri announced the general availability of ArcGIS 10.1 on June 11th 2012.

Moving forward, our objective is to continue development to make the most of all the exciting new possibilities that ArcGIS Server 10.1 offers. Stay tuned for some great new features which we’ll be releasing in the months ahead.

The upcoming version of Geocortex Optimizer (1.6) will include key feature additions and will also be ArcGIS Server 10.1 compliant. Geocortex Optimizer 1.6 is currently undergoing testing and we hope to make  an announcement as to general availability in the next few weeks.