Geocortex licensees need to be aware of a recent decision affecting Microsoft .NET requirements for Geocortex Essentials. Geocortex Essentials 4, which is due to be released towards the end of 2013/early 2014, will move to a minimum required version of .NET 4.5 (Geocortex Essentials currently requires .NET 4.0). Why?

First, it reflects Latitude Geographics’ ongoing commitment to compatibility with Esri ArcGIS. Earlier this year Esri announced that ArcGIS 10.2 will be the last release supporting .NET versions prior to version 4.5.

Second, Geocortex Essentials 4 contains architectural changes and new capabilities that require .NET 4.5. Most of these changes are transparent to our customers until they are expressed in new features like instant search, built-in identity provider for federated authentication, or improvements to Geocortex Workflow Designer.

The change to .NET 4.5 will have deployment implications for Geocortex customers. Geocortex Essentials 3.15 will be the last release to support Windows server environments which do not fully support Microsoft .NET 4.5:

  • Windows XP
  • Windows Server 2003/2003 R2
  • IIS 6

While Geocortex Essentials 4 won’t support server deployments to the above listed operating systems and web servers, web mapping applications you deploy with Geocortex Essentials 4 will still run in web browsers on Windows XP and Windows Server 2003 client machines.

Conversations we've had with customers have revealed very few cases where older servers will require upgrading. Even so, we want our customers to have plenty of lead time to plan an operating system upgrade so that they can move to Geocortex Essentials 4 as soon as it is available. Also note that Geocortex Essentials 3.15 will remain a supported version for some time following the release of Geocortex Essentials 4.