The Geocortex Essentials development team had been working with the pre-releases of AGS 9.3.1 prior to our release of Geocortex Essentials 1.5.2 Service Pack 1, so we were pretty confident that things would go off without a hitch when ArcGIS Server 9.3.1 was officially released.

We've now wrapped up a thorough round of testing using Geocortex Essentials 1.5.2 SP1 and 2.0 Beta 2 with ArcGIS Server 9.3.1.

Our test results are very positive. Essentials 1.5.2 SP1 and 2.0 Beta 2 did not reveal any issues specific to AGS 9.3.1 when using either MXD-based services, or the new MSD-based map services with one exception:

  • Using the ArcMap Layout print functionality (which uses layouts defined in MXDs), will not work when using the new MSD-based map services. The template-based printing feature is still fully functional when using MXD and MSD-based services.

If you are eager to upgrade or have already upgraded, feel free to run your Geocortex Essentials 1.5.2 SP1/2.0 Beta 2 applications on the 9.3.1 release of ArcGIS Server.