On Thursday, November 15th, you may have received a communication from Esri describing an important update for ArcGIS and Transport Layer Security (TLS) Protocol Support. The details on Esri’s announcement can be viewed here.

The TLS 1.2 requirement enforces strong security practices using the highest industry standards to ensure that your data and network are as secure as possible. Geocortex software (including Geocortex Essentials, Geocortex Analytics and Geocortex 5-series products) provides support for accessing services and content from servers secured with TLS 1.2; however, there are Windows operating system requirements that need to be in place to ensure continued operation of your production applications.

 

On servers where Geocortex software is installed, ensure that all Windows security updates have been applied, and/or you have installed Microsoft .NET Framework 4.6 or newer.

End-users working with Geocortex applications using older browsers (Internet Explorer 9 or 10) must manually update their browser settings to ensure compatibility:

  1. Open IE settings in the top right corner, Internet options.

  2. Select the Advanced tab.

  3. Scroll down to the Security section at the bottom of the list.

  4. Click the option to Use TLS 1.2

  5. Click Apply.
  6. Click OK.

*Tip: You can use this resource to determine if your browser supports TLS 1.2.

If you need help ensuring that your operating system and browser are ready to support TLS 1.2, please contact support at support@geocortex.com.